We just updated our CSS/JavaScript Versioning extension and it is now fully compatible with the 1.4 branch and all branches thereafter (1.5, 1.6). Back in the 1.4 branch the feature of merging JS and CSS files was in beta which got finalized in the 1.5 version. As a result some minimal internal changes were made in the core file that we overwrite. With the new version of our extension, you can install it on an older version and still be confident that when you upgrade (say from 1.4 to 1.5) it will still work properly.

Sincerely,
-Ron